Introduction

Help > Introduction
Introduction

This chapter presents the information how to use this manual and how to quick start if you are already familiar with Microsoft Visual Studio and C# programming language.

© 2021 JYTEK company. All rights reserved.


Overview

Help > Introduction > Overview
Overview

The PCIe/PXIe-5500 Series is a family of multifunction data acquisition boards, which can run on PCIe, PXIe, TXI(Thunderbolt) and USB buses (coming soon). Depending on the model number, a PCIe/PXIe-5500 series provide different AI channels, AO channels, sampling rate as shown in Table 1 .

Table 1 PCIe/PXIe-5500 Family and Main Features

Table 2 PCIe/PXIe-5500 on Different Bus

Please check with JYTEK for the latest PCIe/PXIe-5500 series offering.


Main Features

Help > Introduction > Main Features
Main Features

l 32 single-ended or 16 differential 18-bit analog input channels

l 18 bits ADC

l 7 voltage ranges: ±10V/±5V/±2V/±1V/±0.5V/±0.2V/±0.1V

l 64M samples FIFO buffer for analog input

l 4 simultaneous 16-bit analog output channels

l 32M sample FIFO buffer for analog output

l 6 ports digital IO, 8 channels per port

l 4 general 32-bit timer/counter

l DMA for analog input and output

l Analog/Digital/Software Trigger


Abbreviations

Help > Introduction > Abbreviations
Abbreviations

AI: Analog Input

AO: Analog Output

DI: Digital Input

DO: Digital Output

CI: Counter Input

CO: Counter Output

DAQ: Data AcQuisition

ADC: Analog-to-Digital Conversion

DAC: Digital-to-Analog Conversion

PFI: Programmable Function Interface

SE: Single-Ended

RSE: Referenced Single-Ended

NRSE: Non-Referenced Single-Ended

DIFF: Differential

PPM: Parts Per Million


Learn by Example

Help > Introduction > Learn by Example
Learn by Example

JYTEK has added Learn by Example in this manual. We provide many sample programs for this device. Please download the sample programs for this device. You can download a JYPEDIA excel file from our web www.jytek.com. Open JYPEDIA and search for JY5500 in the driver sheet, select JY5500 Examples.zip. In addition to the download information, JYPEDIA also has a lot of other valuable information, JYTEK highly recommend you use this file to obtain information from JYTEK.

Figure 1 JYPEDIA Information

In a Learn by Example section, the sample program is in bold style such as Analog Input-->Winform AI Continuous MultiChannel Soft Trigger; the property name in the sample program is also in bold style such as SamplesToAcquire; the technical names used in the manual is in italic style such as SampleRate. You can easily relate the property names in the example program with the manual documentation.

In an Learn by Example section, the experiment is set up as follow. A PCIe/PXIe-5500 card is plugged in a desktop computer. The PCIe/PXIe-5500 is connected to a TB-68 terminal block. A signal source is also connected to the same terminal block as shown Figure 2.

Figure 2 PCIe/PXIe-5500 experiment

The TB-68 has 4 terminal columns, J1 – J4 and is shown below as Figure 3. In the rest of this manual, the wire connection in each Learn by Example section will be given by the pin numbers only.

Figure 3 TB-68 Terminal Block

Tip: PCIe/PXIe-5500 also has the analog output capability. If you do not have a signal source, you can use the outputs of PCIe/PXIe-5500 as the signal source. In this case you need first run example program Analog Output-->Winform AO Continuous Wrapping Multichannel to generate the output.


AI Hardware Specifications

Help > Hardware > Analog Input > AI Hardware Specifications
AI Hardware Specifications
Analog Input | 5510 | 5511 | 5515 | 5516
Number of channels | 32 SE / 16 DIFF |  | 16 SE / 8 DIFF
ADC resolution (Bits) | 18
Single channel maximum sample rate | 2M Sample/s | 1.25M Sample/s | 2M Sample/s | 1.25M Sample/s
Multichannel maximum sample rate (aggregate) | 1M Sample/s | 625K Sample/s | 1M Sample/s | 625K Sample/s
Clock | 100 MHz
Input range(V) | ±10/±5/±2/±1/±0.5/±0.2/±0.1
Maximum Working Voltage(V) | ±11 V (ref. AIGND)
Input mode | RSE / NRSE / Differential
Input impedance | >1 GΩ||100 pF
Input coupling | DC
Overvoltage protection | ±25 V
CMRR | 85 dB
Crosstalk | Adjacent Channel : -80 dB
 | Non-adjacent Channel : -95 dB
 | Differential: -65 dB
DNL | No Missing Code
INL | 70 ppm of Range Typical
Input FIFO | 64M Samples
Trigger type | Digital, Analog, Software
Trigger mode | StartTrigger, ReferenceTrigger, ReTrigger
External Sampling Clock | <= 1MHz
Analog trigger voltage range | ±10V Software Programmable
Overvoltage Protection | Continuous : 20m A, ±25 V
 | Instantaneous : 40 mA, ±25 V

Table 3 Analog Input Specifications


Basic DC AI Accuracy, DAQ Mode

Help > Hardware > Analog Input > Basic DC AI Accuracy, DAQ Mode
Basic DC AI Accuracy, DAQ Mode

The DC measurement refers to measuring a signal, which either is a DC source or has extremely slow frequency such that the signal voltage changes very little in the measurement window. Please note, the averaging can only be useful if the signal does not change in the averaging window as shown on the left of Figure 4 . The noise is greatly reduced and an accurate measurement is made after averaging.

But if the signal changes in the averaging windows as shown on the right of Figure 4 , the result will be the average of both the signal and the noise. While the noise is reduced as before, the averaging of the signal introduces the measurement error. You cannot use the averaging method if your signal changes in the averaging window!

Figure 4 Averaging in DC Measurements

Table 4 also listed the maximum source signal frequency using the 24 Hr. Column accuracy at the maximum 2MHz sample rate. You can use this number for other calibration columns. But if you have other sample rate or the temperature or multiple-channel adjustment, you should use

to calculate the maximum source frequency. The formulas are same for the DAQ and DS Mode.

The DAQ mode is the normal data acquisition mode commonly found in commercial DAQ hardware. The basic AI DC accuracy Table 4 of the DAQ mode provides accuracy entries when PCIe/PXIe-5500 operates in the single channel mode and within the indicated calibration temperature range. Please note that this accuracy is valid for every single point regardless how many sample points you acquire.

Each entry in the basic accuracy table is a pair of gain and offset coefficients. Using these gain and offset coefficients, your measurement accuracy can be calculated by following fomular:

For example, at the 0.1V range and 24 Hours column, if your measurement or reading is 0.02V, the accuracy of this measurement is:

The basic accuracy table also provides full-scale accuracy entries for a quick and convenient look-up. For example, the full-scale accuracy for the 0.1V range and the 24-Hour calibration column is 46uV.

Table 4 Basic Accuracy in DAQ Mode


Additional DC AI Accuracy Adjustment, DAQ Mode

Help > Hardware > Analog Input > Additional DC AI Accuracy Adjustment, DAQ Mode
Additional DC AI Accuracy Adjustment, DAQ Mode

The AI accuracy will also be affected by the operating temperatures and the multi-channel operating mode. If PCIe/PXIe-5500 operates outside the basic operating range as defined by the basic accuracy table, the additional accuracy entries must be added to the basic accuracy table to obtain the final accuracy.


Temperature Adjustment

Help > Hardware > Analog Input > Additional DC AI Accuracy Adjustment, DAQ Mode > Temperature Adjustment
Temperature Adjustment

The temperature adjustment is needed when the operating temperature is outside the calibration temperature range, such as the Tcal±1ºC range, or the Tcal±5ºC range etc. The temperature coefficients, both the gain and offset coefficients, are provided. These cofficients must be added to the gain and offset coefficients in the basic accuracy table to calculate the accuracy. Table 5 is the additional AI accuracy adjustment table due to the operating temperatures.

Table 5 Additional Accuracy Adjustment due to Temperature, DAQ Mode

For example, at the 0.1V range and 2ºC outside the 24 Hour Tcal±1ºC range, the basic accuracy entry (0.0024%, 0.0437%) must be adjusted to

(0.0024%+0.0007%*2, 0.0437%+0.0015%*2) = (0.0038%, 0.0467%).

The accuracy of the same 0.02V reading value is

The full-scale accuracy numbers are also provided in the additional accuracy table. For example, at the 0.1V range, and 2°C outside 24 Hour Tcal±1ºC range, there is a 2uV/°C adjustment. You will need to add 2*2uV = 4uV to the basic accuracy, and the total accuracy is 46+2*2=50uV.


Multi-Channel Adjustment

Help > Hardware > Analog Input > Additional DC AI Accuracy Adjustment, DAQ Mode > Multi-Channel Adjustment
Multi-Channel Adjustment

When PCIe/PXIe-5500 operates at the multi-channel mode, the channel switching can incur additional errors because it takes time for the voltage to discharge from one channel before the next channel starts acquistion. Because PCIe/PXIe-5500’s 32 channels share one ADC, the channel sample rate of each channel is dedermined by

ChannelSample Rate = Sample Rate/N

where

SampleRate<=1M is selected by the driver software,

N is the total number of channels. N=2,3 …, 32.

Table 6 . lists the additional DC accuracy adjustment. No adjustments are needed for the sample rates lower than or equal to 200K/N. For the sample rate >=500K/N, the additional error increases. In most cases, these higher sample rates are not needed and not recommended for DC measurements. Please refer to 8.4 for details.

The source impedence, cable length and terminal block also affect the accuracy adjustment. Table 6 . uses a 25Ωimpedence source, a JYTEK 2-meter cable and TB68 terminal block. The accuracy adjustment for the longer cable length and larger soure impedence have not been tested.

In the above temperature adjustment example, at the 0.1V range, 2°C outside 24 Hour Tcal±1ºC range, N=2 channels, and the 500K/N sample rate, the total accuracy is 46 + 2*2 +45 uV = 95uV.

Table 6 Additional Accuracy Adjustment due to Multi-Channel Mode


Basic DC AI Accuracy,DS Mode

Help > Hardware > Analog Input > Basic DC AI Accuracy,DS Mode
Basic DC AI Accuracy,DS Mode

PCIe/PXIe-5510 and 5515 is capable to make very accurate DC measurement by using the DS Mode operation. Please note the DS mode is currently available for one channel measurement only. The reason is that the channel switching induces errors that affect the measurement accuracy. The DS mode is not intended for high frequency measurement at all.

In the DS Mode, these boards use the onboard FPGA processing to reduce the noise effect and to improve the AI accuracy. The FPGA processing uses more sample points and will reduce the overall sample rates. For each range, the processing can be different, so the sample rates can also be different. Typically, a slower sample rate delivers better accuracy.

PCIe/PXIe-5510 and 5515 only provides the accuracy entries for several predetermined sample rates. If you choose a different sample rate, you need to use the accuracy entries in the next higher sample rate. For instance, if you choose a 5K sample rate, you need to use the accuracy of the 10K sample rate.

Table 7 is the basic accuracy table in the DS Mode. The additional DC accuracy adjustment due to temperature in the DS Mode is identical to that in the normal DAQ mode as in Table 5 .

Table 7 Basic AI Accuracy in DSMode


AC Accuracy for One Channel

Help > Hardware > Analog Input > AC Accuracy for One Channel
AC Accuracy for One Channel

The AC accuracy is defined as the measurement accuracy of a single tone sinusoidal input signal. If the input the signal is not sinusoidal, the accuracy is not applicable.

Table 8 gives the total AC accuracy specification for PCIe/PXIe-5510. It is for one channel only. There is no AC accuracy specification when the sinusoidal input is greater than 200KHz. The reason is we need at least 5 sample points to describe a time domain sinusoidal waveform.

Table 8 AC Accuracy for One Channel


AC Accuracy for Multiple Channels

Help > Hardware > Analog Input > AC Accuracy for Multiple Channels
AC Accuracy for Multiple Channels

Table 9 shows the AC accuracy for multiple channels. Please note you can only use the 200K/N sample rate. No specifications are provided for other sample rates. At this sample rate, there is no channel switching error. min(20K, 40K/N) indicates the smaller frequency number of 20K and 40K/N Hz. The reason is we need at least 5 sample points to describe a time domain sinusoidal waveform. 200K/N is the channel sample rate, the sinusoidal waveform frequency should <= 40K/N.

Table 9 AC Accuracy for Multiple Channels

For example, if we use all 32 channels, ie N=32, PCIe/PXIe-5510 can still provide AC accuracy from 10Hz to 1.25KHz.


Temperature Adjustment for AC Accuracy

Help > Hardware > Analog Input > Temperature Adjustment for AC Accuracy
Temperature Adjustment for AC Accuracy

At this time, JYTEK only provides 90 days AC accuracy within Tcal±5ºC range. At this time, no other temperature adjustment specifications are provided.


AI Bandwidth

Help > Hardware > Analog Input > AI Bandwidth
AI Bandwidth

Table 10 AI Bandwidth


CMRR

Help > Hardware > Analog Input > CMRR
CMRR

A typical CMRR performance is shown below.

Figure 5 Common Mode Rejection Ratio


Hardwaer Specifications

Help > Hardware > Analog Output > Hardwaer Specifications
Hardwaer Specifications

Table 11 Analog Output Specifications


Basic AO Accuracy

Help > Hardware > Analog Output > Basic AO Accuracy
Basic AO Accuracy

The AO output accuracy of PCIe/PXIe-5500 Series when using the analog output function can be calculated according to the corresponding parameters in the following table

Each entry in the basic accuracy table is a pair of gain and offset coefficients. Using these gain and offset coefficients, your AO output basic accuracy is calculated by following fomular:

For example, at the 5V range and 24 Hours column, if your output is 2V, the accuracy of this measurement is:

The basic accuracy table also provides full-scale accuracy entries for a quick and convenient look-up. For example, the full-scale accuracy for the 5V range and the 24-Hour calibration column is 355uV.

Table 12 Basic AO Accuracy


Additional AO Accuracy Adjustment

Help > Hardware > Analog Output > Additional AO Accuracy Adjustment
Additional AO Accuracy Adjustment

Table 13 is the additional AO accuracy adjustment table. It provides additional accuracy adjustments: temperature adjustment.

Table 13 Additional AO Accuracy

The temperature adjustment is needed when the operating temperature is outside the calibration temperature range, such as the Tcal±1ºC range, or the Tcal±5ºC range etc. The temperature coefficients, both the gain and offset coefficients, are provided. These cofficients must be added to the gain and offset coefficients in the basic accuracy table to calculate the accuracy. For example, at the 5V output and 2ºC outside the 24 Hour Tcal±1ºC range, the basic accuracy entry (0.0015%, 0.0056%) must be adjusted to

(0.0015%+0.0007%*2, 0.0056%+0.0002%*2) = (0.0029%, 0.0060%).

The accuracy of the same 2V output value is

The full-scale accuracy numbers are also provided in the additional accuracy table. For example, at the 5V range, and 2°C outside 24 Hour Tcal±1ºC range, there is a 45uV/°C adjustment. You will need to add 2*45uV = 90uV to the basic accuracy, and the total accuracy is 358+90=448uV.


Digital IO Specifications

Help > Hardware > Digital IO Specifications
Digital IO Specifications

Table 14 Digital IO Specifications


Counter/Timer Specifications

Help > Hardware > Counter/Timer Specifications
Counter/Timer Specifications

Table 15 Counter/Timer Specifications


PFI Specifications

Help > Hardware > PFI Specifications
PFI Specifications

Table 16 PFI Specifications


Power Specification

Help > Hardware > Power Specification
Power Specification

Table 17 Power Specification


Physical and Environment

Help > Hardware > Physical and Environment
Physical and Environment

Table 18 Physical and Environment


Front Panel and Pin Definition

Help > Hardware > Front Panel and Pin Definition
Front Panel and Pin Definition

Figure 6 PXIe/PCIe 5510 Front Panel

PCIe/PXIe-5500 series boards are connected to outside signals by either two 68-pin cables for the 32 channel configurations or one 68-pin cable for 16 channel configurations. Table 19 , Table 20 , Table 21 , Table 22 show the pin definitions for 32 channels and 16 channels of PCIe/PXIe-5500 series boards respectively. Please note that pin definition of connector 0 and 1 is different!

Please also note, for 32 channel device in DIFF mode, the 16 analog input channels are 0~7 and 16~23.

5510/5511 Connector Pin Definition

Table 19 5510 / 5511 Pin Definition

5510/5511 Counter Pin Definition (Connector 0)

Table 20 5510 / 5511 Counter Pin Define

5515/5516 Connector Pin Definition

Table 21 5515 / 5516 Pin Definition

5515/5516 Counter Pin Definition

Table 22 5515 / 5516 Counter Pin Define

Notes to Legend in the Pin Definitions

Table 23 Notes to Legend


System Requirements

Help > Software > System Requirements
System Requirements

PCIe/PXIe-5500 boards can be used in a Windows or a Linux operating system.

Microsoft Windows: Windows 7 32/64 bit, Windows 10 32/64 bit.

Linux Kernel Versions: There are many Linux versions. It is not possible JYTEK can support and test our devices under all different Linux versions. JYTEK will at the best support the following Linux versions.

Table 24 Supported Linux Versions


System Software

Help > Software > System Software
System Software

When using the PCIe/PXIe-5500 in the Window environment, you need to install the following software from Microsoft website:

Microsoft Visual Studio Version 2015 or above,

.NET Framework version is 4.0 or above.

.NET Framework is coming with Windows 10. For Windows 7, please check .NET Framework version and upgrade to 4.0 or later version.

Given the resources limitation, JYTEK only tested PCIe/PXIe-5500 be with .NET Framework 4.0 with Microsoft Visual Studio 2015. JYTEK relies on Microsoft to maintain the compatibility for the newer versions.


C# Programming Language

Help > Software > C# Programming Language
C# Programming Language

All JYTEK default programming language is Microsoft C#. This is Microsoft recommended programming language in Microsoft Visual Studio and is particularly suitable for the test and measurement applications. C# is also a cross platform programming language.


PCIe/PXIe-5500 Series Hardware Driver

Help > Software > PCIe/PXIe-5500 Series Hardware Driver
PCIe/PXIe-5500 Series Hardware Driver

After installing the required application development environment as described above, you need to install the PCIe/PXIe-5500 hardware driver.

JYTEK hardware driver has two parts: the shared common driver kernel software (FirmDrive) and the specific hardware driver.

Common Driver Kernel Software (FirmDrive): FirmDrive is the JYTEK’s kernel software for all hardware products of JYTEK instruments. You need to install the FirmDrive software before using any other JYTEK hardware products. FirmDrive only needs to be installed once. After that, you can install the specific hardware driver.

Specific Hardware Driver: Each JYTEK hardware has a C# specific hardware driver. This driver provides rich and easy-to-use C# interfaces for users to operate various PCIe/PXIe-5500 function. JYTEK has standardized the ways which JYTEK and other vendor’s DAQ boards are used by providing a consistent user interface, using the methods, properties and enumerations in the object-oriented programming environment. Once you get yourself familiar with how one JYTEK DAQ card works, you should be able to know how to use all other DAQ hardware by using the same methods.

Note that this driver does not support cross-process, and if you are using more than one function, it is best to operate in one process.


Install the SeeSharpTools from JYTEK

Help > Software > Install the SeeSharpTools from JYTEK
Install the SeeSharpTools from JYTEK

To efficiently and effectively use PCIe/PXIe-5500 boards, you need to install a set of free C# utilities, SeeSharpTools from JYTEK. The SeeSharpTools offers rich user interface functions you will find convenient in developing your applications. They are also needed to run the examples come with PCIe/PXIe-5500 hardware. Please register and down load the latest SeeSharpTools from our website, www.jytek.com .


Running C# Programs in Linux

Help > Software > Running C# Programs in Linux
Running C# Programs in Linux

Most C# written programs in Windows can be run by MonoDevelop development system in a Linux environment. You would develop your C# applications in Windows using Microsoft Visual Studio. Once it is done, run this application in the MonoDevelop environment. This is JYTEK recommended way to run your C# programs in a Linux environment.

If you want to use your own Linux development system other than MonoDevelop, you can do it by using our Linux driver. However, JYTEK does not have the capability to support the Linux applications. JYTEK completely relies upon Microsoft to maintain the cross-platform compatibility between Windows and Linux using MonoDevelop.


Operating PCIe/PXIe-5500

Help > Operating PCIe/PXIe-5500
Operating PCIe/PXIe-5500

This chapter provides the operation guides for PCIe/PXIe-5500, including AI, AO, DI, DO, Timer and programmable I/O interface, etc.

JYTEK provides extensive examples, on-line help and documentation to assist you to operate the PCIe/PXIe-5500 board. JYTEK strongly recommends you go through these examples before writing your own application. In many cases, an example can also be a good starting point for a user application.


Quick Start

Help > Operating PCIe/PXIe-5500 > Quick Start
Quick Start

After you have installed the driver software and the SeeSharpTools, you are ready to use Microsoft Visual Studio C# to operate the PCIe/PXIe-5500 products.

If you are already familiar with Microsoft Visual Studio C#, the quickest way to use PCIe/PXIe-5500 boards is to go through our extensive examples. We provide source code of our examples. In many cases, you can modify the source code and start to write your applications.

We also provide Learn by Example in the following sections. These examples will help you navigate and learn how to use this PCIe/PXIe-5500.


Data Acquisition Methods

Help > Operating PCIe/PXIe-5500 > Data Acquisition Methods
Data Acquisition Methods

PCIe/PXIe-5500 uses a scanning method to acquire analog data, meaning there is only one ADC chip on the device and all input channels share this ADC. In the scan acquisition mode, you need to configure AI channels and set up some parameters through PCIe/PXIe-5500 driver software. The most important parameters are Data Acquisition mode, Sample Rate, SamplesToAcquire, Channel Count, ChannelRange and Analog Input Terminal Type.

AI Acquisition mode (AIMode): PCIe/PXIe-5500 provides 4 acquisiontion modes, Continuous, Finite, Single Point, Record, which will be described in details in Section 4.2.1-4.2.4.

SampleRate: How fast data are acquired per second per channel. For example, if the sample rate is 1000Hz, you acquire two channels of data, you will have 2000 points/second.

SamplesToAcquire: This parameter behaves differently in the different AI acquisition modes. In the continuous acquisition mode, SamplesToAcuire is the buffer size used in the AI acquisition task, please see Section 4.2.1; in the finite acquisition mode, it is the total number of samples to capture, please see Section 4.2.2.

Channel Count: how many channels you want to collect data. You can set up the channels in different orders, for instance 2,3,1,0. The acquired data will be arranged in the way you specify as shown in Figure 7. In this particular case, Channel Count is 4.

Figure 7 Sample Rate and Internal AD Conversion

ConvertRate denotes the working rate of ADC. In default: ConvertRate = SampleRate * ChannelCount . User can redefine the ConvertRate in our software. If user want to redefine ConvertRate, The following conditions must be met:

Multichannel maximum sample rate (aggregate) >=ConvertRate >= SampleRate * ChannelCount.

User can get Multichannel maximum sample rate (aggregate) from section 2.1.1


Learn by Example 4.2

Help > Operating PCIe/PXIe-5500 > Data Acquisition Methods > Learn by Example 4.2
Learn by Example 4.2

n Connect the two signal source’s positive outputs to PCIe/PXIe-5500 AI Ch0 (AI0+, Pin #68) and AI Ch1 (AI1+, Pin#33), two negative terminals to the ground (AI_GND, Pin#67) as shown in Figure 2 and Figure 3 . (AI0+, AI_GND) and (AI1+, AI_GND) consist of two channels of RSE inputs and they share the same GND.

n Set a sinewave signal (f=4Hz, Vpp=5V) and a squarewave signal (f=4Hz, Vpp=5V).

n Open Analog Input-->Winform AI Continuous MultiChannel, set the following numbers as shown. This sample program will continuously acquire data from multiple channels.

Figure 8 Continuous MultiChannel Paraments

Ø SampleRate is set by Sample Rate

Ø Samples to Acquire is the samples to be acquired for each channel in one block. The continuous mode will acquire blocks after blocks until Stop button is pressed.

n When start is clicked, it generates a software trigger, which starts the acquisition. The result is shown below.

Figure 9 MultiChannel Continuous Acquisition


Continuous Acquisition

Help > Operating PCIe/PXIe-5500 > Data Acquisition Methods > Continuous Acquisition
Continuous Acquisition

An AI acquisition task will acquire the data continuously until the task is stopped. The PCIe/PXIe-5500 device will continue acquiring data and save the data in a circular buffer. You specify how many samples to read back by the user buffer’s length, if your program does not read the data fast enough, the circular buffer may overflow. In this case, the driver software will throw out an erro message.

Tip: User buffer’s length 1/10th to 1/4th SampleRate is a good start.


Finite Acquisition

Help > Operating PCIe/PXIe-5500 > Data Acquisition Methods > Finite Acquisition
Finite Acquisition

In the Finite Acquisition mode, an AI acquisition task will capture specific total number of samples by the parameter, SamplesToAcquire.

You can use the sample program Analog Input --> Winform AI Finite to learn more about Finite Acquisition.


Single Point Acquisition

Help > Operating PCIe/PXIe-5500 > Data Acquisition Methods > Single Point Acquisition
Single Point Acquisition

In the Single Acquisition mode, it is to capture a single sample for each acquisition.

You can use sample program: Analog Input --> Console AI Single Point to learn more about the single point Acquisition.


Record Acquisition

Help > Operating PCIe/PXIe-5500 > Data Acquisition Methods > Record Acquisition
Record Acquisition

AI Task will continuously capture the data and then save them to a storage disk. During the capturing process, user can preview the captured data randomly when the capturing process is available. The mode is particularly useful for high-speed acquisition and recording applications.


Analog Input Terminal Type

Help > Operating PCIe/PXIe-5500 > Analog Input Terminal Type
Analog Input Terminal Type

The PCIe/PXIe-5500 provide 3 analog input terminal types:

n Differential (DIFF)

n Referenced Single-Ended (RSE)

n Non-Referenced Single-Ended (NRSE)

The DIFF connection is recommended for ground-referenced signal sources and it is usually better in rejecting the common-mode noise. However, to acquire one input signal, two AI channels are required to form the differential pair. The RSE and NRSE are recommended when the input signal sources are floating signals. In RSE and NRSE modes, these floating signal sources all share the same ground reference (AI_GND). Because of it, the RSE and NRSE modes can acquire twice as many channels than the DIFF mode. Appendix 8 has more details on these 3 modes.


DIFF Mode

Help > Operating PCIe/PXIe-5500 > Analog Input Terminal Type > DIFF Mode
DIFF Mode

The DIFF mode connects signal’s positive side to AI’s positive input, signal’s grounded negative side to AI’s negative input as shown in Figure 10 . The common noise appears on both positive and negative terminals of the differential amplifier, thus it will be cancelled out. Therefore, the DIFF mode has better signal-to-noise ratio (SNR). Please see Appendix 1 Common Analog Measurement Issues for more explainations.

Figure 10 Differential Mode for Grounding Signals


Learn by Example 4.3.1

Help > Operating PCIe/PXIe-5500 > Analog Input Terminal Type > DIFF Mode > Learn by Example 4.3.1
Learn by Example 4.3.1

n Open the program Analog Input-->Winform AI Continuous MultiChannel

n Connect the two signal source’s positive outputs to PCIe/PXIe-5500 AI Ch0 (AI0+, Pin #68) and AI Ch1 (AI1+, Pin#33), two negative terminals to AI Ch0 negative (AI0-, Pin#34) and AI Ch1 negative (AI1-, Pin#66) as shown in Figure 2 and Figure 3 . (AI0+, AI0-) and (AI1+, AI1-) consist of two pairs of DIFF inputs;

n Choose Differential in AI Terminal;

n Set other numbers as shown and click start.

Figure 11 Choose Differential In AI Terminal


RSE Mode

Help > Operating PCIe/PXIe-5500 > Analog Input Terminal Type > RSE Mode
RSE Mode

In the RSE mode, all input signals’ negative sides are connected to the AI ground of Instrumentation Amplifier, as shown in Figure 12 . This mode works for measurements from floating sources. The RSE mode is suitable when these two conditions exist:

n The input signals are floating, meaning they are not conneted to the ground

n When the common mode noise is low, meaning a clean environment.

The RSE mode offers twice as many measurement channels as the DIFF mode. Please see Appendix 1 Common Analog Measurement Issues for more explainations.

Figure 12 RSE Mode for Floating Signals


NRSE Mode

Help > Operating PCIe/PXIe-5500 > Analog Input Terminal Type > NRSE Mode
NRSE Mode

The NRSE mode is recommended for the measurement of ground-referenced signals, as shown in Figure 13 . NRSE is also called the pseudo differential mode, because it looks very similar to a DIFF connection. In this mode, the PCIe/PXIe-5500 device offers a special reference point, AI SENSE. Instead of connecting two gounds directly, signal’s ground and PXI device’s ground, the input signals’ ground is connected to AI SENSE to avoid the ground loop bias. The PCIe/PXIe-5500is also designed to better reject the common mode noise than the RSE mode. Therefore the NRSE model still offers twice many channels as the DIFF mode. Please see Appendix 1 Common Analog Measurement Issues for more explainations.

Figure 13 NRSE Mode for Grounding Signals


Learn by Example 5.3.3

Help > Operating PCIe/PXIe-5500 > Analog Input Terminal Type > NRSE Mode > Learn by Example 5.3.3
Learn by Example 5.3.3

n Open the program Analog Input-->Winform AI Continuous MultiChannel.

n This Example needs two TB-68 terminal blocks, Connector0 and Connector1 and two cables, which are connected to PCIe/PXIe-5500. Connect the two signal source’s positive outputs to PCIe-5510 AI Ch0 (AI0+, Pin #68) and AI Ch1 (AI1+, Pin#33), two negative terminals to AI_SENSE 0 (Pin#62) of the first TB-68 and AI_SENSE 1 (Pin#62) of the second TB-68 as shown in Figure 2 and Figure 3 . (AI0+, AI_SENSE 0) and (AI1+, AI_SENSE 1) consist of two channels of NRSE inputs.

n Choose the NRSE in AI Terminal

n Set other numbers as shown and click start.

Figure 14 Choose NRSE In AI Terminal


Trigger Source

Help > Operating PCIe/PXIe-5500 > Trigger Source
Trigger Source

There are 4 trigger types: Immediate trigger, Software trigger, Analog trigger, and Digital trigger. The trigger type is a property and set by driver software.


Immediate trigger

Help > Operating PCIe/PXIe-5500 > Trigger Source > Immediate trigger
Immediate trigger

This trigger mode does not require configuration and is triggered immediately when an operation starts. The operation can be AI, AO, DI, DO, CI, CO etc.


Learn by Example 4.4.1

Help > Operating PCIe/PXIe-5500 > Trigger Source > Immediate trigger > Learn by Example 4.4.1
Learn by Example 4.4.1

n Use the same program and connection as in Learn by Example 4.2 .

Figure 15 Immediate trigger Paraments

Ø With Immediate trigger you can click Start to generate the task instead of sending a trigger signal.


Software Trigger

Help > Operating PCIe/PXIe-5500 > Trigger Source > Software Trigger
Software Trigger

A software trigger must be configured by the driver software. The trigger starts when a trigger software routine is called.


Learn by Example 4.4.2

Help > Operating PCIe/PXIe-5500 > Trigger Source > Software Trigger > Learn by Example 4.4.2
Learn by Example 4.4.2

n Connect the signal source’s positive terminal to PCIe/PXIe-5500 AI Ch0 (AI0+, Pin#68), the negative terminal to the ground (AI_GND, Pin#67) as shown in Figure 2 and Figure 3 . (AI0+, AI_GND) consists of a RSE input.

n Set a sinewave signal (f=4Hz, Vpp=5V).

n Open Analog Input-->Winform AI Continuous Soft Trigger, set the following numbers as shown.

n Click Start to run the task.

Figure 16 Software trigger Paraments

Ø Data will not be acquired until there is a positive signal from Software Trigger when Send Soft Trigger is clicked.

n After sending the trigger signal, the result will be like this:

Figure 17 Software trigger Acquisition


External Analog Trigger

Help > Operating PCIe/PXIe-5500 > Trigger Source > External Analog Trigger
External Analog Trigger

You can assign one of measurement channels as the analog trigger source. PCIe/PXIe-5500 provides three analog trigger modes:

n Edge comparator,

n Hysteresis comparator,

n Window comparator.

Analog trigger threshold range can be arbitrarily selected in the effective range of the selected channel. When setting the threshold, please pay attention to the physical unit currently in use.

Edge comparator

In the Edge comparator, there are two trigger conditions: Rising Slope Trigger and Falling Slope Trigger.

Rising Slope Trigger: The Edge comparator output is high when the signal goes above the threshold; the output is low when the signal goes below the threshold as shown in Figure 18 .

Falling Slope Trigger: The Edge comparator output is high when the signal goes below the threshold; the output is low when the signal goes above the threshold as shown in Figure 19 .

Figure 18 Rising Slope Trigger

Figure 19 Falling Slope Trigger

Hysteresis Comparator

The hysteresis comparator is designed for preventing spurious triggering. You can set hysteresis region by setting high threshold and low threshold. There are two trigger conditions: Hysteresis with Rising Slope Trigger and Hysteresis with Falling Slope Trigger.

Hysteresis with Rising Slope Trigger: The Hysteresis comparator output is high when the signal must first be below the low threshold, then goes above the high threshold. The output will change to low when the signal goes below the low threshold as shown in Figure 20 .

Hysteresis with Falling Slope Trigger: The Hysteresis comparator output is high when the signal must first be above the high threshold, then goes below the low threshold. The output will change to low when the signal goes above the high threshold as shown in Figure 21 .

Figure 20 Hysteresis with Rising Slope Trigger

Figure 21 Hysteresis with Falling Slope Trigger

Window comparator

The window comparator is designed to acquire signal from interesting window by setting High Threshold and Low Threshold. There are two trigger conditions: Entering Window Trigger and Leaving Window Trigger.

Entering Window Trigger: The window comparator output is high when the signal enters the window defined by the Low Threshold and High Threshold. The output will change to low when the signal leaves the window as shown in Figure 22 .

Leaving Window Trigger: The window comparator output is high when the signal leaves the window defined by the Low Threshold and High Threshold. The output will change to low when the signal enters the window as shown in Figure 23 Leaving Window Trigger .

Figure 22 Entering Window Trigger

Figure 23 Leaving Window Trigger


Learn by Example 4.4.3

Help > Operating PCIe/PXIe-5500 > Trigger Source > External Analog Trigger > Learn by Example 4.4.3
Learn by Example 4.4.3

n Connect the signal source’s positive terminal to PCIe/PXIe-5500 AI Ch0 (AI0+, Pin#68), the negative terminal to the ground (AI_GND, Pin#67) as shown in Figure 2 and Figure 3 . (AI0+, AI_GND) consists of a RSE input.

n Set a sinewave signal (f=4Hz, Vpp=5V).

n Open Analog Input-->Winform AI Continuous Analog Trigger, set the following numbers as shown.

Figure 24 Analog Trigger Paraments

Ø Modes of the Analog Trigger are set by Trigger Comparator. Set it to Edge.

Ø The edge of EdgeComparator set by Trigger Edge. (Rising and Falling)

Ø Trigger source can be any channel of PCIe/PXIe-5500 analog input. Set it to Channel_0.

Ø According to the rules of Rising mentioned above, the signal acquisition will not start until it raises to 2.0 V, which is set by Threshold above.

n Click Start, a message will appear in the lower left corner:

Figure 25 Waiting For Trigger

Ø This indicates the data acquisition will start only after a triggering event. In this example a trigger signal will occur when the hysteresis comparator meets the condition explained in 4.4.3 .

n The result is shown below:

Figure 26 Analog Trigger Acquisition

Ø The signal starts at 2.0V, which matches the Edge mode set before.


External Digital Trigger

Help > Operating PCIe/PXIe-5500 > Trigger Source > External Digital Trigger
External Digital Trigger

PCIe/PXIe-5500 supports different external digital trigger sources from PXI Trigger bus (PXI_TRIG<0..7>), PXI_STAR and connectors of front panel (PFI). The high pulse width of digital trigger signal must be longer than 20 ns for effective trigger. The module will monitor the signal on digital trigger source and wait for the rising edge or falling edge of digital signal which depending on the set trigger condition, then cause the module to acquire the data as shown in Figure 27

Figure 27 External Digital Trigger


Learn by Example 4.4.4

Help > Operating PCIe/PXIe-5500 > Trigger Source > External Digital Trigger > Learn by Example 4.4.4
Learn by Example 4.4.4

n Connect the signal source two positive terminals to PCIe/PXIe-5500 AI Ch0, (AI0+, Pin #68) and digital trigger source (PFI 0, Pin#11), two negative terminals to the ground of analog input (AI_GND, Pin#67) and the ground of digital input/output (DGND, Pin#44) as shown in Figure 2 and Figure 3. (AI0+, AI_GND) consists of a RSE input. (PFI0, DGND) provides the trigger signal.

n Set a sinewave signal (f=4Hz, Vpp=5V) and a squarewave signal (f=4Hz, Vpp=5V).

n Open Analog Input-->Winform AI Continuous Digital Trigger, set the following numbers as shown.

Figure 28 Digital Trigger Paraments

Ø Trigger Source must match the pin on 5510.

Ø There are two Trigger Edge: Rising and Falling.

n Click Start and the result shows below:

Figure 29 Digital Trigger Acquisition

Ø Since the squarewave is used for the digital trigger source, when a rising edge of the squarewave occurs, the digital trigger will be activated, and the data acquisition will start.


Trigger Mode

Help > Operating PCIe/PXIe-5500 > Trigger Mode
Trigger Mode

The PCIe/PXIe-5500's analog inputs support several trigger modes: start trigger, reference trigger, and re-trigger.


Start Trigger

Help > Operating PCIe/PXIe-5500 > Trigger Mode > Start Trigger
Start Trigger

In this mode, data acquisition begins immediately after the trigger. This trigger mode is suitable for continuous acquisition and finite acquisition. As shown in Figure 30 .

Figure 30 Start Trigger


Reference Trigger

Help > Operating PCIe/PXIe-5500 > Trigger Mode > Reference Trigger
Reference Trigger

This trigger mode is suitable for finite acquisition. In this mode, user can set the number of pre-trigger samples. The default number of pre-trigger points is 0. First you need to start the data acquisition. When the reference trigger condition is met, the routine will return the acquired data points. If when the points less than the pre-trigger samples, the trigger signal be ignored. An example is show below.

Example

l Total samples: 1000;

l Channel Count: 1

l Pre-trigger samples: 10;

l After triggering, it returns total 1000 samples, 10 being pre-triggered, 990 after triggering

The principle is shown in Figure 31.

Figure 31 Reference Trigger


ReTrigger

Help > Operating PCIe/PXIe-5500 > Trigger Mode > ReTrigger
ReTrigger

PCIe/PXIe-5500 series products support retrigger mode. In the retrigger mode, you can set the number of retrigger and the length of each acquisition. Assuming that the number of re triggers is n and the length of each trigger acquisition is m, the length of all acquisition data is n * m * channelcount. Show in Figure 32.

When the number of retrigger is - 1, it is infinite.

Figure 32 ReTrigger


Learn by Example 4.5

Help > Operating PCIe/PXIe-5500 > Trigger Mode > Learn by Example 4.5
Learn by Example 4.5

n Connect the signal source’s positive terminal to PCIe-5500PCIe/PXIe-5500 AI Ch0 (AI0+, Pin#68), the negative terminal to the ground (AI_GND, Pin#67) as shown in Figure 2 and Figure 3. (AI0+, AI_GND) consists of an RSE input.

n Set a sinewave signal (f=4Hz, Vpp=5V).

n Open Analog Input-->Winform AI Finite Analog Trigger, set the following numbers as shown.

Figure 33 Retrigger Paraments

Ø You can use three different kinds of triggers in this program as mentioned in 4.5. Start Trigger and Reference Trigger can be set by Trigger Mode. For ReTrigger can be used by changing the numbers in Retrigger Count.

Ø PretriggerSamples is set by Pretrigger Samples.

n Now the trigger is a Start Trigger. Click Start to begin the data acquisition, the result is shown below:

Figure 34 Retrigger In Start Trigger Mode

n Now change the Trigger Mode to Reference mode with Pretrigger Samples 1000. A different result shows below:

Figure 35 Retrigger In Reference Trigger Mode

Ø You can see the horizontal movement between two signals due to the change of Trigger Mode.

n Now change the mode of trigger to Retrigger through giving Retrigger Count a number other than 0 and click Start. A message will appear in the lower left corner: “Complete the [image] trigger”.

Figure 36 Complete Retrigger Count

Ø It shows the acquisition process through every trigger signal.


AO Operations

Help > Operating PCIe/PXIe-5500 > AO Operations
AO Operations

The PCIe/PXIe-5500 AO provides 16-bit simultaneous outputs. The analog output has three modes of operation: Finite, ContinuousWrapping, and ContinuousNoWrapping.


Finite Output

Help > Operating PCIe/PXIe-5500 > AO Operations > Finite Output
Finite Output

The finite output requires the user to write a piece of data. After starting the AO, it starts to output the written data until the output is completed.


Learn by Example 4.6.1

Help > Operating PCIe/PXIe-5500 > AO Operations > Finite Output > Learn by Example 4.6.1
Learn by Example 4.6.1

n Connect PCIe/PXIe-5500 AO Ch0 (AO0, Pin #22) to AI Ch0 (AI0+, Pin#68), Ground of AO0 (AO_GND, Pin#55) to Ground of AI0 (AI_GND, Pin#67). (AI0+, AI_GND) consists of a RSE input; (AO0, AO_GND) consists of an output.

PCIe/PXIe-5500 sends an analog signal through (AO0, AO_GND) and reads back the signal from (AI0+, AI_GND).

n Open Analog Input-->Winform AI Continuous, set the following numbers as shown.

Figure 37 AI Continuous Paraments

n Click Start to start the data acquisition.

n Open Analog Output-->Winform AO Finite, set the following numbers as shown:

Figure 38 AO Finite Output Paraments

n Click Start to generate a SineWave. The generated signal is shown below:

Figure 39 AO Finite Signal

n And the received signal is shown below.

Figure 40 AI Acquisition Signal

Ø The analog signal is successfully generated and received by PCIe/PXIe-5500.


Continuous NoWrappping Output

Help > Operating PCIe/PXIe-5500 > AO Operations > Continuous NoWrappping Output
Continuous NoWrappping Output

The continuous acyclic output needs to write a piece of data before starting the AO. After the AO starts, user needs to continuously write new data to ensure the continuous output of the AO.


Learn by Example 4.6.2

Help > Operating PCIe/PXIe-5500 > AO Operations > Continuous NoWrappping Output > Learn by Example 4.6.2
Learn by Example 4.6.2

n Connect PCIe/PXIe-5500 AO Ch0 (AO0, Pin #22) to AI Ch0 (AI0+, Pin#68), Ground of AO0 (AO_GND, Pin#55) to Ground of AI0 (AI_GND, Pin#67). (AI0+, AI_GND) consists of a RSE input; (AO0, AO_GND) consists of an output.

n PCIe/PXIe-5500 sends an analog signal through (AO0, AO_GND) and reads back the signal from (AI0+, AI_GND).

n Open Analog Input-->Winform AI Continuous, set the following numbers as shown.

Figure 41 AI Continuous Paraments

n Click Start to start the data acquisition.

n Open Analog Output-->Winform AO Continuous NoWrapping, set the following numbers as shown:

Figure 42 AO ContinuousNoWrapping Output Paraments

Ø In no wrapping analog output you can change the parameter of the signal whenever you want in Waveform Configuration when generating the wave. After the configuration you should click Update to apply the changes.

n Click Start to generate a sine wave first. The result is shown below.

Figure 43 AO ContinuousNoWrapping Signal

n And the received signal is shown below.

Figure 44 AI Acquisition AO Sin Signal

n Now change the Wave Type to SquareWave and click Update to generate it. The result is shown below.

Figure 45 Update AO Square Signal

n And the received signal is shown below.

Figure 46 AI Acquisition AO Square Signal

Ø The analog signal is successfully generated and received by PCIe/PXIe-5500.


Continuous Wrapping Output

Help > Operating PCIe/PXIe-5500 > AO Operations > Continuous Wrapping Output
Continuous Wrapping Output

The continuous loop output first writes a piece of data before starting the AO. After the AO starts, the board will repeatedly output this data until user sends a stop command.


Learn by Example 4.6.3

Help > Operating PCIe/PXIe-5500 > AO Operations > Continuous Wrapping Output > Learn by Example 4.6.3
Learn by Example 4.6.3

n Connect PCIe/PXIe-5500 AO Ch0 (AO0, Pin #22) to AI Ch0 (AI0+, Pin#68), Ground of AO0 (AO_GND, Pin#55) to Ground of AI0 (AI_GND, Pin#67). (AI0+, AI_GND) consists of a RSE input; (AO0, AO_GND) consists of an output.

n PCIe/PXIe-5500 sends an analog signal through (AO0, AO_GND) and reads back the signal from (AI0+, AI_GND).

n Open Analog Input-->Winform AI Continuous, set the following numbers as shown.

Figure 47 AI Continuous Paraments

n Click Start to start the data acquisition.

n Open Analog Output-->Winform AO Continuous Wrapping, set the numbers as shown.

Figure 48 AO Continuous Wrapping Paraments

n Click Start to generate the signal. The result is shown below.

Figure 49 AO Continuous Wrapping Signal

n And the received signal is shown below.

Figure 50 AI Acquisition AO Signal

Ø The analog signal is successfully generated and received by PCIe/PXIe-5500.


Digital I/O Operations

Help > Operating PCIe/PXIe-5500 > Digital I/O Operations
Digital I/O Operations

The PCIe/PXIe-5500 provides powerful programmable digital I/O functions.


Static DI/DO

Help > Operating PCIe/PXIe-5500 > Digital I/O Operations > Static DI/DO
Static DI/DO

Programmable I/O supports static TTL, 6 ports (0,1,2,3,4,5) which are in total 48 digital I/O channels. User can acess these I / O information through software polling.


Learn by Example 4.7.1

Help > Operating PCIe/PXIe-5500 > Digital I/O Operations > Static DI/DO > Learn by Example 4.7.1
Learn by Example 4.7.1

n In this example PCIe/PXIe-5500 outputs a digital signal by its DO function and reads it back by its DI function.

n Connect Connector1 of PCIe/PXIe-5500 to the TB-68 terminal block according to Figure 3 .

n Connect Port 1/Line 0~7 (P1.0~P1.7) to Port 2/Line 0~7 (P2.0~2.7). PCIe/PXIe-5500 sends a digital signal through Port 1 and reads the signal back from Port 2.

n Open the first program Digital Output-->Winform DO SinglePoint.

n Select port 1 for Digital Output, Set Line 1,3,5,7 in High-Level positions, make sure all other lines are in Low-Level positions. Click Start to generate the High-Levels as shown.

Figure 51 Single Digital Output

n Open the second program Digital Input-->Winform DI SinglePoint.

n Select port 2 for Digital Input as shown, and click Check DI Status. The result is shown below.

Figure 52 Single Digital Input

Ø The result matches the high and low levels set before.


Dynamic DI/DO

Help > Operating PCIe/PXIe-5500 > Digital I/O Operations > Dynamic DI/DO
Dynamic DI/DO

The PCIe/PXIe-5500 supports both dynamic DI/DO operation with a maximum sample rate (update rate) of up to 10MHz. User can acquire or output digital waveforms in this way.


Learn by Example 4.7.2

Help > Operating PCIe/PXIe-5500 > Digital I/O Operations > Dynamic DI/DO > Learn by Example 4.7.2
Learn by Example 4.7.2

n In this example PCIe/PXIe-5500 outputs a squarewave by its DO function and reads it back by its DI function.

n Connect Connector1 of PCIe/PXIe-5510/5511 or Connector0 of PCIe/PXIe-5515/5516 to the TB-68 terminal block according to Figure 3.

n Connect PCIe/PXIe-5510/5511 Port 1/Line 0~7 (P1.0~P1.7) to Port 2/Line 0~7 (P2.0~2.7) or PCIe/PXIe-5515/5516 Port 0/Line 0~7 (P0.0~P0.7) to Port 1/Line 0~7 (P1.0~1.7). PCIe/PXIe-5500 sends digital signals through Port 1/Port 0 and reads them back from Port 2/Port 1.

n Open Digital Input-->Winform DI Continuous and set the numbers as shown. Select port 2(PCIe/PXIe-5510/5511) or port 1(PCIe/PXIe-5515/5516).

Figure 53 DI Continuous Paraments

n Click Start to begin the data acquisition.

n Open Digital Output--> Winform DO Continuous NoWrapping and set the numbers as shown.

n Click Start to generate the signal. The result is shown below.

Figure 54 DO ContinuousNoWrapping Output

n In program Winform DI Continuous, you can see the acquired signal. Select port 1(PCIe/PXIe-5510/5511) or port 0(PCIe/PXIe-5515/5516).

Figure 55 DI Continuous Acquisition

Ø The digital signal is successfully generated and acquired by PCIe/PXIe-5500.


Counter Input Operations

Help > Operating PCIe/PXIe-5500 > Counter Input Operations
Counter Input Operations

The PCIe/PXIe-5500 has four or two identical 32 bits timers/counters.

Figure 56 Counter Terminal

Each counter has seven input terminals and one output terminal, and these terminals have different functions in different counter input application types, including:

l Edge Counting

l Pulse Measurement

l Frequency Measurement

l Period Measurement

l Two-Edge Separation

l Quadrature Encoder (X1, X2, X4)

l Two-Pulse Encoder

For buffered acquisition, each counter has a separate DDR storage space and requires a sample clock.

For each counter input application type, the measured signal needs to be connected to different terminals, as shown in the following table.

Figure 57 Counter Signal Wiring Instruction


Edge Counting

Help > Operating PCIe/PXIe-5500 > Counter Input Operations > Edge Counting
Edge Counting

The counter counts the number of active edges of input signal.

Timing

1) Single Mode

The count value is written to the register on each rising edge or falling edge of the signal to measure as shown in Figure 58 .

Figure 58 Simple Edge Counting in Single Mode

2) Finite/Continuous Mode with Internal Sample Clock

The count value is stored into the buffer on each rising edge or falling edge of the sample clock as shown in Figure 59 .

Figure 59 Buffered Edge Counting with Internal Sample Clock

3) Finite/Continuous Mode with Implicit Sample Clock

The count value is stored into the buffer on each rising edge or falling edge of the signal to measure as shown in Figure 60 .

Figure 60 Simple Edge Counting with Implicit SampleClk

Counting Direction

User can control the counting direction through software configuration or by an input signal with AUX terminal. When using an input signal to control the counting direction, the counter counts up when the signal is high and counts down when the signal is low as shown in Figure 61 .

Figure 61 Count Direction


Learn by Examples4.8.1

Help > Operating PCIe/PXIe-5500 > Counter Input Operations > Edge Counting > Learn by Examples4.8.1
Learn by Examples4.8.1

n Connect the signal source’s positive terminal of a signal source to PCIe-5510 counter0’s edge counting source (CTR0_Source/A, Pin#11), negative terminal to the ground (DGND, Pin#44) as shown in Figure 2 and Figure 3 . (CTR0_Source, DGND) consists of an edge counting counter input and they share the same ground.

n Set a squarewave signal (f=1Hz, Vpp=5V).


Single Mode

Help > Operating PCIe/PXIe-5500 > Counter Input Operations > Edge Counting > Learn by Examples4.8.1 > Single Mode
Single Mode

n Open Counter Input-->Winform CI Single EdgeCounting, set the following numbers as shown:

Figure 62 EdgeCounting For Single Mode

Ø Counter Direction is set by Counter Direction.

Ø The table in the sample program is a connection diagram for your convenience.

n The rising edge counter works when Start is clicked.

n The result is shown by Counter Value. In this example the Counter Value increases by 1 every second for a 1Hz sinewave.


Finite/Continuous Mode

Help > Operating PCIe/PXIe-5500 > Counter Input Operations > Edge Counting > Learn by Examples4.8.1 > Finite/Continuous Mode
Finite/Continuous Mode

n Change the squarewave frequency to 50 Hz.

n Open Counter Input-->Winform CI Finite/Continuous EdgeCounting, set the following numbers as shown:

Figure 63 EdgeCounting For Finite Mode

Ø The table in the sample program is a connection diagram for your convenience.

Ø Counter Direction is set by Counter Direction.

Ø There are two clock sources in PCIe/PXIe-5500 Internal and Implicit: This example uses Internal mode set by Clock Source.

n Click Start to start counting by rising edge. The result is shown below:

Figure 64 Counter Values For Internal Clock

Ø The numbers are stored in a buffer CounterValues.

n Change the Clock Source to Implicit:

Figure 65 Counter Values For Implicit Clock

Ø The numbers are stored in a buffer CounterValues.

Ø The counter values are different as before because of the change from Clock Source.


Pulse Measurement

Help > Operating PCIe/PXIe-5500 > Counter Input Operations > Pulse Measurement
Pulse Measurement

The counter measures the high-level and low-level duration of signal.

Timing

1) Single Mode

The count value of the duration of the high-level or low-level is written to the register on each rising or falling edge of the pulse to measure, as shown in Figure 66 .

Figure 66 Pulse Measurement in Single Mode

2) Finite/Continuous Mode with Internal Sample Clock

The count value of the duration of the high or low level is stored into the buffer on each rising or falling edge of the sample clock, as shown in Figure 67 .

Figure 67 Pulse Measurement with Internal SampleClk

3) Finite/Continuous Mode with Implicit Sample Clock

The count value of the duration of the high-level or low-level is stored into the buffer on each rising or falling edge of the pulse to measure, as shown in Figure 68 .

Figure 68 Pulse Measurement with Implicit SampleClk


Learn by Examples 4.8.2

Help > Operating PCIe/PXIe-5500 > Counter Input Operations > Pulse Measurement > Learn by Examples 4.8.2
Learn by Examples 4.8.2

n Connect the signal source’s positive terminal to PCIe-5510 counter0’s pulse measure source (CTR0_Gate/Z, Pin#10), negative terminal to the ground (DGND, Pin#44) as shown in Figure 2 and Figure 3 . (CTR0_Gate/Z, DGND) consists of a pulse measure counter input and they share the same ground.

n Set a squarewave signal (f=1Hz, Duty Cycle=50%, Vpp=5V).


Single Mode

Help > Operating PCIe/PXIe-5500 > Counter Input Operations > Pulse Measurement > Learn by Examples 4.8.2 > Single Mode
Single Mode

n Open Counter Input-->Winform CI Single PulseMeasure, set the following numbers as shown:

Figure 69 Pulse Measure For Single Mode

Ø The table in the sample program is a connection diagram for your convenience.

n Click Start to start measuring the pulses. The result is shown by High Pulse Measure(S) and Low Pulse Measure(S):

Figure 70 Pulse Measure Value For Single Mode

Ø The numbers show the duration of High/Low Pulse in one signal period and match the duty cycle set before.


Finite/Continuous Mode

Help > Operating PCIe/PXIe-5500 > Counter Input Operations > Pulse Measurement > Learn by Examples 4.8.2 > Finite/Continuous Mode
Finite/Continuous Mode

n Change the frequency of Squarewave to 50 Hz.

n Open Counter Input-->Winform CI Finite/Continuous PulseMeasure, set the following numbers as shown:

Figure 71 Pulse Measure For Finite Mode

Ø The table in the sample program is a connection diagram for your convenience.

n Click Start to begin the finite/continuous pulse measurement. The result is shown below:

Figure 72 Pulse Measure Values For Finite Mode

Ø The numbers show the duration of High/Low Pulse in one signal period and match the duty cycle set before.

n Please refer to Learn by Examples4.8.1 Finite/Continuous Mode about the difference between Internal and Implicit.


Frequency Measurement

Help > Operating PCIe/PXIe-5500 > Counter Input Operations > Frequency Measurement
Frequency Measurement

The counter measures the frequency of signal to measure.

Timing

1) Single Mode

Frequency Measurement without sample clock is actually using Pulse Width Measurement internally, refer to chapter 4.8.2 for more information.

Every time the user reads the data, driver will automatically calculate the frequency ( [image] ) according to the HighTick ( [image] ), LowTick ( [image] ) values and known frequency of the timebase ( [image] ) according to the formula 1 and return the result to the user.

To configure the counter to work in this mode, set JY5500CITask.Mode to CIMode.Single.

2) Finite/Continuous Mode with Internal Sample Clock (Averaging)

Between every two rising edges of the sample clock, the counter counts the numbers of full periods ( [image] ) of the signal to measure, and the number of rising edges of timebase ( [image] ) during those full periods. These two values are stored into the buffer on each rising edge of the sample clock, as shown in Figure 73 .

Figure 73 Frequency Measurement with Internal Sample Clock

Every time the user reads the data, driver will automatically calculate the frequency ( [image] ) according to the buffered values and known frequency of the timebase ( [image] ) by using following formula and return the result to user.

3) Finite/Continuous Mode with Implicit Sample Clock

Frequency Measurement with implicit sample clock is actually using Pulse Measurement internally. refer to chapter 4.8.2 for more information.

Every time the user reads the data, driver will automatically calculate the frequency ( [image] ) according to the HighTick ( [image] ) and LowTick ( [image] ) values according to the formula 1 and return the result to the user.


Learn by Examples 4.8.3

Help > Operating PCIe/PXIe-5500 > Counter Input Operations > Frequency Measurement > Learn by Examples 4.8.3
Learn by Examples 4.8.3

n Connect the signal source’s positive terminal to PCIe-5510 counter0’s frequency measure source (CTR0_Gate/Z, Pin#10), negative terminal to the ground (DGND, Pin#44) as shown in Figure 2 and Figure 3 . (CTR0_Gate/Z, DGND) consists of a frequency measure counter input and they share the same ground.

n Set a squarewave signal (f=50Hz, Duty Cycle=50%, Vpp=5V).


Single Mode

Help > Operating PCIe/PXIe-5500 > Counter Input Operations > Frequency Measurement > Learn by Examples 4.8.3 > Single Mode
Single Mode

n Open Counter Input-->Winform CI Single Frequency Measure and click Start. The result is shown below by Frequency Measure (Hz):

Figure 74 Frequency Measure For Single Mode

Ø The table in the sample program is a connection diagram for your convenience.

Ø The result matches the frequency set before.


Finite/Continuous Mode

Help > Operating PCIe/PXIe-5500 > Counter Input Operations > Frequency Measurement > Learn by Examples 4.8.3 > Finite/Continuous Mode
Finite/Continuous Mode

n Open Counter Input-->Winform CI Finite/Continuous Frequency Measure.

Figure 75 Frequency Measure For Continuous Mode

Ø The table in the sample program is a connection diagram for your convenience.

Ø Internal and Implicit Sample Clocks are set by Clock Source as before. (Please refer to Finite/Continuous Mode for more information.)

n Click Start and it will show the frequency 50 as set in the signal resource.

Figure 76 Frequency Measure Values


Period Measurement

Help > Operating PCIe/PXIe-5500 > Counter Input Operations > Period Measurement
Period Measurement

The counter measures the period of signal to measure. Period Measurements is using Frequency Measurement internally and returns the inverse result of Frequency Measurement. Refer to chapter 4.8.3 for more information.


Learn by Examples 4.8.4

Help > Operating PCIe/PXIe-5500 > Counter Input Operations > Period Measurement > Learn by Examples 4.8.4
Learn by Examples 4.8.4

n Connect the signal source’s positive terminal to PCIe-5510 counter0’s period measure source (CTR0_Gate/Z, Pin#10), negative terminal to the ground (DGND, Pin#44) as shown in Figure 2 and Figure 3 . (CTR0_Gate/Z, DGND) consists of a period measure counter input and share the same ground.

n Set a squarewave signal (f=200Hz, Duty Cycle=50%, Vpp=5V).


Single Mode

Help > Operating PCIe/PXIe-5500 > Counter Input Operations > Period Measurement > Learn by Examples 4.8.4 > Single Mode
Single Mode

n Open Counter Input-->Winform CI Single Period Measure and click Start. The result is shown below by Period Measure(S):

Figure 77 Peroid Measure For Single Mode

Ø The table in the sample program is a connection diagram for your convenience.

Ø The result of Period Measure(S) shows the correspond to the frequency set before.


Finite/Continuous Mode

Help > Operating PCIe/PXIe-5500 > Counter Input Operations > Period Measurement > Learn by Examples 4.8.4 > Finite/Continuous Mode
Finite/Continuous Mode

n Open Counter Input-->Winform CI Finite/Continuous Period Measure and click Start. The result is shown below by PeriodMeasure (S).

Figure 78 Peroid Measure For Continuous Mode

Ø The table in the sample program is a connection diagram for your convenience.

Ø The result of Period Measure(S) shows the correspond to the frequency set before.


Two-Edge Separation

Help > Operating PCIe/PXIe-5500 > Counter Input Operations > Two-Edge Separation
Two-Edge Separation

The counter measures the separation between the rising edges of two signals.

Timing

1) Single Mode

The number of rising edges of timebase between the rising edge of the first signal and the rising edge of the second signal is written to the register on each rising edge of the second signal.

The number of rising edges of timebase between previous rising edge of the second signal and current rising edge of the first signal is written to the register on each rising edge of the first signal as shown in Figure 79 .

Figure 79 Two-Edge Separation in Single Mode

2) Finite/Continuous Mode with Internal Sample Clock:

The count values of rising edges of timebase between first signal and second signal are stored into buffer on each rising edge of the sample clock, as shown in Figure 80 .

Figure 80Two-Edge Separation with Internal Sample Clock

3) Finite/Continuous Mode with Implicit Sample Clock

The count values of rising edges of timebase between first signal and second signal are stored into buffer on each rising edge of the first signal, as shown in Figure 81 .

Figure 81 Two-Edge Separation with Implicit Sample Clock


Learn by Examples 4.8.5

Help > Operating PCIe/PXIe-5500 > Counter Input Operations > Two-Edge Separation > Learn by Examples 4.8.5
Learn by Examples 4.8.5

n Connect the signal source’s two positive terminals to PCIe-5510 first signal input (squarewave, CTR0_Gate/Z, Pin #10) and second signal input (squarewave, CTR0_AUX/B, Pin#43), two negative terminals to the ground (DGND, Pin#44) and (D_GND, Pin#9) as shown in Figure 2 and Figure 3 .

n Set a squarewave signal (f=1Hz, Phase=0°) and a squarewave signal (f=1Hz, Phase=135°).


Single Mode

Help > Operating PCIe/PXIe-5500 > Counter Input Operations > Two-Edge Separation > Learn by Examples 4.8.5 > Single Mode
Single Mode

n Open Counter Input-->Winform CI Single TwoEdgeSeparation Measure and click Start. The result is shown below by First to Second(S) and Second to First(S), which represent the time difference between the rising edges of the two signals:

Figure 82 Two-EdgeSeparation Measure For Single Mode

Ø The table in the sample program is a connection diagram for your convenience.

Ø Due to the phase-difference between First Signal and Second Signal, First to Second and Second to First are different and summarize as 1.


Finite/Continuous Mode

Help > Operating PCIe/PXIe-5500 > Counter Input Operations > Two-Edge Separation > Learn by Examples 4.8.5 > Finite/Continuous Mode
Finite/Continuous Mode

n Open Counter Input-->Winform CI Finite/Continuous TwoEdge Separation Measure and click Start. The result is shown below by First to Second(S) and Second to First(S), which represent the time difference between the rising edges of the two signals:

Figure 83 Two-EdgeSeparation Measure For Finite Mode

Ø The result in this picture is similar to the result in Single Mode before.

Ø The table in the sample program is a connection diagram for your convenience.


Quadrature Encoder

Help > Operating PCIe/PXIe-5500 > Counter Input Operations > Quadrature Encoder
Quadrature Encoder

The quadrature encoder includes three encoding types: x1, x2, and x4.

Encoding Type

1) x1 Encoding

When A leads B, the count increase occurs on the rising edge of A; when B leads A, the count decrease occurs on the falling edge of A as shown in Figure 84 .

Figure 84 Quadrature Encoder x1 Mode

2) x2 Encoding

When A leads B, the count increase occurs on the rising edge and the falling edge of A; when B leads A, the count reduction occurs on the rising edge and falling edge of A as shown in Figure 85 .

Figure 85 Quadrature Encoder x2 Mode

3) x4 Encoding

When A leads B, the increase of count occurs on the rising and falling edges of A and B. When B leads A, the decrease in count occurs on the rising and falling edges of A and B. As shown in Figure 86 .

Figure 86 Quadrature Encoder x4 mode

Channel Z Behavior

The phase is reloaded when channel Z is high, A and B are low.

Timing

Take Encoding x1 mode as an example.

1) Single Mode

The count value is written to the register on each rising edge of the signal A, as shown in Figure 58 .

To configure the counter to work in this mode, set JY5500CITask. Mode to CIMode.Single.

2) Finite/Continuous Mode with Internal Sample Clock

The count value is stored into the buffer on each rising edge of the sample clock, as shown in Figure 87 .

Figure 87 Quadrature Encoder x1 with Sample Clock

3) Finite/Continuous Mode with Implicit Sample Clock

The count value is stored into the buffer every time it changes, as shown in Figure 88 .

Figure 88 Quadrature Encoder x4 with Implicit Sample Clock


Learn by Examples 4.8.6

Help > Operating PCIe/PXIe-5500 > Counter Input Operations > Quadrature Encoder > Learn by Examples 4.8.6
Learn by Examples 4.8.6

n Connect the signal source’s two positive terminals to PCIe-5510 first signal input (sinewave, CTR0_Source/A, Pin #11) and second signal input (squarewave , CTR0_AUX/B, Pin#43), two negative terminals to the ground (DGND, Pin#44) and (D_GND, Pin#9) as shown in Figure 2 and Figure 3 . (CTR0_Source/A, DGND) consists of the first signal to be measured; (CTR0_AUX/B, D_GND) consists of the second signal to be measured.

n Set a sqaurewave signal (f=10Hz, Phase=90°) and a squarewave signal (f=10Hz, Phase=0°).


Single Mode

Help > Operating PCIe/PXIe-5500 > Counter Input Operations > Quadrature Encoder > Learn by Examples 4.8.6 > Single Mode
Single Mode

n Open Counter Input--> Winform CI Single QuadEncoder and click Start. The result is shown below by CounterValue according to the counting rules explained in 4.8.6 :

Figure 89 QuadEncoder For Single Mode

Ø The table in the sample program is a connection diagram for your convenience.

Ø Encoding Type is set by Encode Type (x1, x2, x4).

Ø When the encode type is changed from x1 to x2 and x4, you can see the rising speed of CounterValue is twice and four times than x1Mode.


Continuous Mode

Help > Operating PCIe/PXIe-5500 > Counter Input Operations > Quadrature Encoder > Learn by Examples 4.8.6 > Continuous Mode
Continuous Mode

n Open Counter Input--> Winform CI Continuous QuadEncoder and click Start. The result is shown below by CounterValues.

Figure 90 QuadEncoder For Continuous Mode

Ø The table in the sample program is a connection diagram for your convenience.

Ø Encoding Type is set by Encode Type (x1, x2, x4).

Ø When the encode type is changed from x1 to x2 and x4, you can see the rising speed of CounterValue is twice and four times than x1Mode.


Two-Pulse Encoder

Help > Operating PCIe/PXIe-5500 > Counter Input Operations > Two-Pulse Encoder
Two-Pulse Encoder

The count value increases on the rising edge of A and decreases on the rising edge of B.

Timing

1) Single Mode

The count value is written to the register on each rising edge of the signal A, and signal B, as shown in Figure 91 .

Figure 91 Two-Pulse Encoder in Single Mode

2) Finite/Continuous Mode with Internal Sample Clock

The count value is stored into the buffer on each rising edge of the sample clock, as shown in Figure 92 .

Figure 92 Two-Pulse Encoder with Internal Sample Clock

3) Finite/Continuous Mode with Implicit Sample Clock

The count value is stored into the buffer every time it changed, as shown in Figure 93 .

Figure 93 Two-Pulse Encoder with Implicit Sample Clock


Learn by Examples 4.8.7

Help > Operating PCIe/PXIe-5500 > Counter Input Operations > Two-Pulse Encoder > Learn by Examples 4.8.7
Learn by Examples 4.8.7

n Connect the signal source’s two positive terminals to PCIe-5510 first signal input (squarewave, CTR0_Source/A, Pin #11) and second signal input (squarewave, CTR0_AUX/B, Pin#43), two negative terminals to the ground (DGND, Pin#44) and (D_GND, Pin#9) as shown in Figure 2 and Figure 3 .

n Set a sqaurewave signal (f=40Hz) and a squarewave signal (f=40Hz).


Single Mode

Help > Operating PCIe/PXIe-5500 > Counter Input Operations > Two-Pulse Encoder > Learn by Examples 4.8.7 > Single Mode
Single Mode

n Open Counter Input-->Winform CI Single Two PulseEncoder and set the numbers as shown.

Figure 94 Two-PulseEncoder For Single Mode

Ø The table in the sample program is a connection diagram for your convenience.

n Click Start to start counting. You can see a continuously rising of the Counter Value, which follows the counting rules explained in this chapter.


Finite Mode

Help > Operating PCIe/PXIe-5500 > Counter Input Operations > Two-Pulse Encoder > Learn by Examples 4.8.7 > Finite Mode
Finite Mode

n Change the frequency of the second channel squarewave from 50Hz to 120Hz.

n Open Counter Input-->Winform CI Finite Two PulseEncoder and set the numbers as shown.

Figure 95 Two-PulseEncoder For Finite Mode

Ø The table in the sample program is a connection diagram for your convenience.

n Click Start and the result is shown above by Counter Value in the right list, which follows the counting rules explained in this chapter.


Continuous Mode

Help > Operating PCIe/PXIe-5500 > Counter Input Operations > Two-Pulse Encoder > Learn by Examples 4.8.7 > Continuous Mode
Continuous Mode

n Change the frequency of the second squarewave back to 50 Hz.

n Open Counter Input-->Winform CI Continuous Two PulseEncoder and set the numbers as shown.

Figure 96 Two-PulseEncoder For Continuous Mode

Ø The table in the sample program is a connection diagram for your convenience.

n Click Start and you can see a group of rising numbers in CounterValues, which follows the counting rules explained in this chapter.


Single Pulse Output

Help > Operating PCIe/PXIe-5500 > Counter Output Operations > Single Pulse Output
Single Pulse Output

The PCIe/PXIe-5500 timer/counter can output a single pulse with a specified pulse width. The timing diagram of the pulse output is shown in Figure 97 .

Figure 97 Single Pulse Output

In single pulse output mode, the user could set up the pulse width by configuring the frequency and duty cycle.

If you want to generate a single pulse with 1 ms pulse width, the parameter, frequency should be setup 500Hz and the duty cycle is 50%. Here is the formula for frequency setting:

Frequency = 1 / (1ms / 0.5) = 500Hz


Learn by Example 4.9.1

Help > Operating PCIe/PXIe-5500 > Counter Output Operations > Single Pulse Output > Learn by Example 4.9.1
Learn by Example 4.9.1

n To see the signal that PCIe/PXIe-5500 Counter Output generates, it is recommended to connect PCIe/PXIe-5500 Counter Output (CTR0_OUT, Pin#2) to PCIe/PXIe-5500 AI Ch0 input (AI0+, Pin#68). Please note Counter Output and AI Ch0 input share the same ground so only one connection is needed.

n Open Counter Output-->Winform CO Single and click Start and set the numbers as follow:

Figure 98 Single Pulse Generation

Ø The table in the sample program is a connection diagram for your convenience.

Ø The frequency and duty cycle of the pulse are set by Frequency and Duty Cycle.

n Please refer Learn by Example 4.2 to configure an analog input to receive the signal from Counter Output.

n Click Start to generate a single pulse as shown.

Figure 99 AI Acquisition Single Pulse


Finite Pulse Output

Help > Operating PCIe/PXIe-5500 > Counter Output Operations > Finite Pulse Output
Finite Pulse Output

The pulse output timing is as shown in Figure 100 .

Figure 100 Finite Pulse Output

In finite pulse output mode, the user is required to configure the output frequency, duty cycle and the number of output pulses.

Assuming that the pulse width to be output by the user is 1ms, the frequency calculated according to the duty cycle of 50% is as follows:

Set frequency = 1 / (1ms / 0.5) = 500Hz

That is to say, when the user sets the frequency as 500Hz and the duty cycle as 0.5, a limited pulse of 1ms pulse width will be obtained.


Learn by Example 4.9.2

Help > Operating PCIe/PXIe-5500 > Counter Output Operations > Finite Pulse Output > Learn by Example 4.9.2
Learn by Example 4.9.2

n To see the signal that PCIe/PXIe-5500 Counter Output generates, it is recommended to connect PCIe/PXIe-5500 Counter Output (CTR0_OUT, Pin#2) to PCIe/PXIe-5500 AI Ch0 input (AI0+, Pin#68). Please note Counter Output and AI Ch0 input share the same ground so only one connection is needed.

n Open Counter Output-->Winform CO Finite and click Start and set the numbers as follow:

Figure 101 Finite Pulses Generation

Ø The table in the sample program is a connection diagram for your convenience.

Ø The frequency and duty cycle of the pulse are set by Frequency and Duty Cycle.

n Please refer Learn by Example 4.2 to configure an analog input to receive the signal from Counter Output.

n Click Start to generate the pulse shown below.

Figure 102 AI Acquisition Finite Pulse

Ø According to the picture, the duty cycle is 0.5 as set before.


Continuous Pulse Output

Help > Operating PCIe/PXIe-5500 > Counter Output Operations > Continuous Pulse Output
Continuous Pulse Output

The pulse output timing is shown in Figure 103 below.

Figure 103 Continuous Pulse Output

In continuous output mode, you need to configure the output frequency and duty cycle. After starting the output, the pulse signal with fixed frequency and duty cycle will be output continuously.


Learn by Example 4.9.3

Help > Operating PCIe/PXIe-5500 > Counter Output Operations > Continuous Pulse Output > Learn by Example 4.9.3
Learn by Example 4.9.3

n To see the signal that PCIe/PXIe-5500 Counter Output generates, it is recommended to connect PCIe/PXIe-5500 Counter Output (CTR0_OUT, Pin#2) to PCIe/PXIe-5500 AI Ch0 input (AI0+, Pin#68). Please note Counter Output and AI Ch0 input share the same ground so only one connection is needed.

n Open Counter Output-->Winform CO Continuous and click Start and set the numbers as follow:

Figure 104 Continuous Pulse Generation

Ø The table in the sample program is a connection diagram for your convenience.

Ø The frequency and duty cycle of the pulse are set by Frequency and Duty Cycle.

n Change the Duty Cycle to 0.7 for instance. The result is shown below.

Figure 105 AI Acquisition Continuous Pulse

Ø According to the picture, the duty cycle is 0.7 as set before.


System Synchronization Interface（SSI）for PCIe Modules

Help > Operating PCIe/PXIe-5500 > System Synchronization Interface（SSI）for PCIe Modules
System Synchronization Interface（SSI）for PCIe Modules

The synchronization between PCIe modules are handled differently from the PXIe synchronization, it is implemented by the system synchronization interface (SSI). SSI is designed as a bidirectional bus and it can synchronize up to four PCIe modules. One PCIe module is designated as the master module and the other PCIe modules are designated as the slave modules.

Figure 106 SSI Connector in PCIe-5500

Table 25 SSI Connector Pin Assignment for PCIe-5500


DIP Switch in PCIe-5500

Help > Operating PCIe/PXIe-5500 > DIP Switch in PCIe-5500
DIP Switch in PCIe-5500

PCIe-5500 series modules have a DIP switch. The card number can be adjusted manually by changing the DIP switch setting, which is used to identify the boards with different slot positions.

For example, if you want to set the card number to 3, you could turn the position 2 and 1 of the DIP switch to the ON position and the orthers to OFF. See below for details.

Figure 107 DIP Switch in PCIe-5500

Table 26 Relationship between switch position and slot number


Calibration

Help > Calibration
Calibration

PCIe/PXIe-5500 Series boards are precalibrated before the shipment. We recommend you recalibrate PCIe/PXIe-5500 board periodically to ensure the measurement accuracy. A commonly accepted practice is one year. If for any reason, you need to recalibrate your board, please contact JYTEK.


Using PCIe/PXIe-5500 in Other Software

Help > Using PCIe/PXIe-5500 in Other Software
Using PCIe/PXIe-5500 in Other Software

While JYTEK’s default application platform is Visual Studio, the programming language is C#, we recognize there are other platforms that are either becoming very popular or have been widely used in the data acquisition applications. Among them are Python, C++ and LabVIEW. This chapter explains how you can use PCIe/PXIe-5500 DAQ card using one of this software.


Python

Help > Using PCIe/PXIe-5500 in Other Software > Python
Python

JYTEK provides and supports a native Python driver for PCIe/PXIe-5500 boards. There are many different versions of Python. JYTEK has only tested in CPython version 3.5.4. There is no guarantee that JYTEK python drivers will work correctly with other versions of Python.

If you want to be our partner to support different Python platforms, please contact us.


C++

Help > Using PCIe/PXIe-5500 in Other Software > C++
C++

We recommend our customers to use C# drivers because C# platform deliver much better efficiency and performance in most situations. We also provide C++ drivers and examples in the Qt IDE, which can be downloaded from web. However, due to the limit of our resources, we do not actively support C++ drivers. If you want to be our partner to support C++ drivers, please contact us.


LabVIEW

Help > Using PCIe/PXIe-5500 in Other Software > LabVIEW
LabVIEW

LabVIEW is a software product from National Instruments. JYTEK does not support LabVIEW and will no longer provide LabVIEW interface to PCIe/PXIe-5500 boards. Our third-party partners may have LabVIEW support to PCIe/PXIe-5500 boards. We can recommend you if you want to convert your LabVIEW applications to C# based applications.


JYTEK China

Help > About JYTEK > JYTEK China
JYTEK China

Founded in June, 2016, JYTEK China is a leading Chinese test & measurement company, providing complete software and hardware products for the test and measurement industry. The company is a joint venture between Adlink Technologies and a group of experienced professionals form the industry. JYTEK independently develop the software and hardware products and is entirely focused on the Chinese market. Our Shanghai headquarters and production service center have regular stocks to ensure timely supply; we have R&D centers in Xi'an and Chongqing to develop new products; we also have highly trained direct technical sales representatives in Shanghai, Beijing, Tianjin, Xi'an, Chengdu, Nanjing, Wuhan, Haerbin, and Changchun. We also have many partners who provide system level support in various cities.


JYTEK Korea and JYTEK In Other Countries

Help > About JYTEK > JYTEK Korea and JYTEK In Other Countries
JYTEK Korea and JYTEK In Other Countries

JYTEK Korea was the first JYTEK enterprise outside China to promote JYTEK products. Together with Adlink Technologies and JYTEK China, JYTEK is expanding to more countries. Each JYTEK location is an independently owned and operated franchise. It shares JYTEK’s philosophy and business approach. Together JYTEK entities promote the JYTEK brand, technology, and products.


JYTEK Hardware Products

Help > About JYTEK > JYTEK Hardware Products
JYTEK Hardware Products

According to JYTEK’s agreement with our equity partner Adlink Technologies, JYTEK’s hardware is manufactured by the state-of-art manufacturing facility located in Shanghai Zhangjiang Hi-Tech Park. Adlink has over 20 years of the world-class low-volume and high-mix manufacturing expertise with ISO9001-2008, China 3C, UL, ROHS, TL9000, ISO-14001, ISO-13485 certifications. Its 30,000 square meters facilities and three high-speed Panasonic SMT production lines can produce 60,000 pieces boards/month; it also has full supply chain management - planning, sweeping, purchasing, warehousing and distribution. Adlink’s manufacturing excellence ensures JYTEK’s hardware has word-class manufacturing quality.

One core technical advantage is JYTEK’s pursue for the basic and fundamental technology excellence. JYTEK China has developed a unique PCIe, PXIe, USB hardware driver architecture, FirmDrive, upon which many our future hardware will be based.

In addition to our own developed hardware, JYTEK also rebrands Adlink’s PXI product lines. In addition, JYTEK has other rebranding agreements to increase our hardware coverage. It is our goal to provide the complete product coverage in PXI and PCI modular instrumentation and data acquisition.


JYTEK Software Platform

Help > About JYTEK > JYTEK Software Platform
JYTEK Software Platform

JYTEK has developed a complete software platform, SeeSharp Platform, for the test and measurement applications. We leverage the open sources communities to provide the software tools. Our platform software is also open sourced and is free, thus lowering the cost of tests for our customers. We are the only domestic vendor to offer complete commercial software and hardware tools.


JYTEK Warranty and Support Services

Help > About JYTEK > JYTEK Warranty and Support Services
JYTEK Warranty and Support Services

With our complete software and hardware products, JYTEK is able to provide technical and sales services to wide range of applications and customers. In most cases, our products are backed by a 1-year warranty. For technical consultation, pre-sale and after-sales support, please contact JYTEK of your country.


Floating Signals and Ground Referenced Signals

Help > Appendix 1 Common Analog Measurement Issues > Floating Signals and Ground Referenced Signals
Floating Signals and Ground Referenced Signals

Signals to be measured often fall into two categories: floating and ground referenced. The floating signals include battery output, isolated output, thermocouples etc; the ground referenced signals include most instrumentation output signals. Some instruments also offered isolated floating output.


Differential, NRSE, RSE Modes

Help > Appendix 1 Common Analog Measurement Issues > Differential, NRSE, RSE Modes
Differential, NRSE, RSE Modes

The DAQ boards have three measurement modes: differential (DIFF), non-referenced singled end (NRSE), and the referenced single end (RSE). The NRSE mode is also referred as the pseudo differential mode. Under the NRSE mode, the DAQ card provides a common connecting terminal, referred as AI_Sensing. The negative ends of input signal and the DAQ boards are all connected to this terminal, making it look like the differential mode. Thus, the NRSE mode can handle twice as many channels as the DIFF mode.

The three measurement modes and the two types of input signals, floating and ground referenced, form 6 different measurement scenarios as shown in the following.

Figure 108 Six Measurement Scenarios

In the first 5 scenarios, VAB is measured voltage. But in the 6th scenario, both the measured signal and the DAQ have own grounds. The two ground may have a voltage difference VBC. The actual measurement is VAC=VAB+VBC, not VAB. Due to the ground noise, VBC is quite noisy. This affects the measurement accuracy. The caution must be taken using 6th mode.


Reducing the Common Mode Voltage Effect

Help > Appendix 1 Common Analog Measurement Issues > Reducing the Common Mode Voltage Effect
Reducing the Common Mode Voltage Effect

In the first 2 modes, the measured signal is floating. It is quite often that the common mode voltage will appear. To reduce this effect on the measurement accuracy, a resister can be added as shown. The value of this resister depends on the impedance of the signal source. As a rule of thumb, R should be 1000 times of the signal source output impedance, roughly 10K to 100KΩ. At this level, R has very little impact on the measurement.

Figure 109 Using Resister to Reduce Common Mode Voltage Effect


DC, AC and DSA Mode

Help > Appendix 1 Common Analog Measurement Issues > DC, AC and DSA Mode
DC, AC and DSA Mode

Figure 110 shows three different measurement modes: DC, AC and DSA. It is important to know what type of the measurement you are making. Table 27 shows differences and features in these three modes.

Figure 110 DC, AC and DSA Mode

Table 27 DC, AC, DSA Measurements


DC Mode

Help > Appendix 1 Common Analog Measurement Issues > DC, AC and DSA Mode > DC Mode
DC Mode

In a DC mode, the signal frequency f should be zero or very small. Many times, engineers use averaging to reduce the noise effect. But inappropriate use of averaging will not reduce the noise effect but introduce the error. Given the Total Accuracy Ɛ, from Sections 2.1.2, 2.1.3, 2.1.4, the maximum source signal frequency f should be bounded by:

where fs is the sample rate. This formula can be used in both the DAQ and the DS Mode. This formula suggests that a faster sampling device such as PCIe/PXIe-5500 can allow bigger signal changes and still achieve excellent accuracy.


AC Mode

Help > Appendix 1 Common Analog Measurement Issues > DC, AC and DSA Mode > AC Mode
AC Mode

The AC mode traditionally measures power line voltage of 50Hz or 60Hz, but has been extended to other frequencies. Due to the alternating nature of the AC signal, the average cannot be done in the time domain. If averaging must be used, it is used in the frequency domain when measuring the power spectrum.

If you use the 1M/N maximum channel sample rate of PCIe/PXIe-5500 in the multi-channel mode, the channel switching error cannot be ignored, as seen in Table 6. If you need better accuracy, you should consider using the simultaneous DAQ devices such as JYTEK PXIe-5315. These devices do not use scanning mode. Rather, each channel is serviced by a dedicated ADC to avoid the channel switching error. This ensures better AC accuracy as well as better synchronization.

Another use of the AC measurement is to analyze the signal’s change. In this case, the sample rate must be sufficiently higher than the signal frequency to catch the changing nature of the signal. As a rule of thumb, 5 times of the signal frequency is often used.


DSA Mode

Help > Appendix 1 Common Analog Measurement Issues > DC, AC and DSA Mode > DSA Mode
DSA Mode

The DSA (Dynamic Signal Analysis) mode mostly measures the signal frequency spectrum. In order to reduce the noise and increase the dynamic range, an anti-aliasing filter is used. Similar to the simultaneous mode, each channel is serviced by a dedicated ADC. To meet the sampling theorem, the sample rate fs should be at least 2.5 times of the signal frequency.

PCIe/PXIe-5500 boards are not designed for the DSA measurements. There is no anti-aliasing filter in a PCIe/PXIe-5500 board.


Statement

Help > Statement
Statement

The hardware and software products described in this manual are provided by JYTEK China, or JYTEK in short.

This manual provides the product review, quick start, some driver interface explanation for JYTEK PCIe/PXIe-5500 Series family of multi-function data acquisition boards. The manual is copyrighted by JYTEK.

No warranty is given as to any implied warranties, express or implied, including any purpose or non-infringement of intellectual property rights, unless such disclaimer is legally invalid. JYTEK is not responsible for any incidental or consequential damages related to performance or use of this manual. The information contained in this manual is subject to change without notice.

While we try to keep this manual up to date, there are factors beyond our control that may affect the accuracy of the manual. Please check the latest manual and product information from our website.

Shanghai Jianyi Technology Co., Ltd.

Address: Room 201, Building 3, NO.300 Fangchun Road, Shanghai.

Post Code: 201203

Tel: 021-5047 5899

Website: www.jytek.com